Service Distruption
Incident Report for Accredible
Resolved
Issue with EU Api and Credential Display has been resolved.
Posted Sep 16, 2020 - 11:18 UTC
Investigating
EU Api and Credential Display are currently down.

Accredible is now investigating.
Posted Sep 16, 2020 - 11:06 UTC