Service Disruption
Incident Report for Accredible
Resolved
This incident has been resolved. We're still investigating the cause.
Posted Sep 09, 2018 - 20:56 UTC
Investigating
We are currently investigating the issue.
Posted Sep 09, 2018 - 20:49 UTC
This incident affected: Credential View, Management Dashboard, API, and Background Processing.