Service Performance Degradation
Incident Report for Accredible
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 10:20 UTC
Monitoring
A fix has been implemented and we're monitoring.
Posted Apr 29, 2020 - 10:16 UTC
Investigating
We're still seeing performance issues, please disregard the previous update.
Posted Apr 29, 2020 - 09:41 UTC
This incident affected: Management Dashboard, API, and Background Processing.